Tag Archives: ATI

ATI Eyefinity with 3 monitors and Color scheme problem solved (kindof)

Some time ago I bought ATI 5750 Eyefinity edition to use with 3 computer displays. The problem was, that it is impossible to use 3rd monitor with ‘passive DisplayPort to DVI cable’.

The solution for me was to use second video card, which led to another problem / error – The color scheme has been changed to Windows 7 Basic.

Yesterday I solved both problems by buying a new HP ZR24w 24-inch LCD Monitor with 3 inputs – VGA, DVI-D and DisplayPort and 5 USB 2.0. It is an expensive monitor (~600 USD including VAT), but monitor has nice ‘Pivot rotation’ feature and Native resolution 1920 x 1200.

So my new setup:

  • LG 37″ LCD TV Full HD – using hdmi – hdmi cable
  • HP 24″ LCD 1200×1920 – using DisplayPort – DisplayPort cable
  • Samsung 19″ LCD – using DVI – VGA (D-sub) – VGA cable

Old setup:

New setup:

My old Samsung 22″ LCD 1680×1050 goes to 2 monitor setup – 46 inch Samsung LE46B55 + Samsung 22″. This setup runs on two EVGA GTX470 cards in SLI mode.

Windows problem: The color scheme has been changed to Windows 7 Basic

A week ago I posted in Microsoft Forum about my continuing ATI / AERO problem.

This problem started to appear after I could not make my ATI Eyefinity work with 3 monitors. What I did, is added another old ATI card, so now I have two ATI cards with 3 monitors.

Here is what I wrote in MS Forums:

My configuration:

  • Intel i7 with 12GB of RAM
  • Windows 7 Ultimate 64-bit
  • Two ATI cards:
    • ATI Radeon 3450 (512MB)
    • ATI Radeon 5750 (1024MB Gddr5)
  • Three monitors – 1920×1080, 1280×1024, 1680×1050

The problem:

  • at random Aero theme switches to Basic
  • last two times it was It seems that it always happens when I was connected to Remote Desktop to Windows 7 Ultimate 32-bit

Error massage in Systray:
The color scheme has been changed to Windows 7 Basic
The current color scheme has exceeded its allowed memory so the color scheme has been automatically changed to improve performance. Click to see more information.

Screen:
The color scheme has been changed to Windows 7 Basic.

If I click for more info, it opens Windows Help with some info, like “A program that you’re running is incompatible with Aero themes.”, “Your laptop might be running low on battery power”, “Your computer’s hardware configuration or screen resolution was changed.”, “Your computer does not have enough memory to run all of the programs” and “Click to open the Aero troubleshooter.‌”

Aero troubleshooter.

  • Troubleshooting couldn’t identify the problem.

Also, I fully understand that “A program that you’re running is incompatible with Aero themes.” sometime kicks in, for example using Oracle SQL Developer, but this is not a case.

Workaround / temporary fix

  • I right click Desktop – Personalize, then I choose any theme (does not matter if Aero or not), then again on my theme, and Aero works again till I open Remote Desktop, then after a couple minutes problem reappears.

I am not alone
There are many users with two video cards (Windows 7 and Vista) that have the same problem:

Drivers

It can not be ATI drivers, because other users have similar issues with nVidia cards. I have ATI drivers:

  • Driver Date: 3/2/2010, version 8.712.0.0
  • ATI Catalyst 10.3 Suite for Windows 7 (64 bit)

After a week

Jetta48 said that this is something to do with ‘Mirror drivers’, but I couldn’t confirm that, because this problem is reproducible with 3 monitors and 2 video cards, but with one card and two monitors everything works without any problems.

Today (28 Apr) Debra-Support Engineer asked if I got through Guided Help: Troubleshoot Aero problems in Windows 7 (kb 976170). It seems that this is the same troubleshooter, that is offered right after problem appears, and the result is the same:
Troubleshooting couldn’t identify the problem. (You can try exploring other options that might be helpful. Explore additional options (that leads to Control Panel\All Control Panel Items\Troubleshooting\Additional Information). Close the troubleshooter)
Troubleshooting couldn't identify the problem

Update 30 Apr.

I am very certain, that issue appears only when Remote Desktop Connection is open.

Another workaround is to use Remote Desktop in non-full-screen video mode. In this case, occasionally Banner pops up, saying:
Windows has detected that your computer’s performance is slow – Click to see more information and options.

Screen shot:
Windows has detected that your computer's performance is slow

If you click on it, it says (used copy / paste):
[Window Title]
Windows

[Main Instruction]
Do you want to change the color scheme to improve performance?

[Content]
The current color scheme, Windows Aero, is using most of its dedicated memory, which can result in slower computer performance. To free up some memory for better computer performance, try closing some open windows or changing the color scheme to Windows 7 Basic.

[Keep the current color scheme] [Change the color scheme to Windows 7 Basic ]

[Footer]
How do I decide whether to change the color scheme to improve performance?

Screen shot:
Do you want to change the color scheme to improve performance

Update Apr 26, 2013.
Thanks to Jean Marc!

Well I THINK I found a solution to get rid of the messages, it seems to work for me without any problems, please give me some feedbacks on your results.
I am using three monitors with different cards and I get the message like you guys.

  1. Open the Start menu, and type gpedit.msc in the search line and press Enter
  2. In the left pane, go to :User Configuration, /Administrative Templates/Windows Components, and Application Compatibility.
  3. In the right pane, right click on Turn off Program Compatibility Assistant and click on Edit
  4. Select disable to turn it off, and vice versa when you want to turn it back on.

It seems to work fine for me.
Give me some feedback on this please.

ATI Eyefinity with 3 monitors – Unable to save display settings

Today I bought ATI 5750 Eyefinity edition. I wanted to enable 3 monitors with one video card as advertised. My setup:

  • LG 37″ LCD TV Full HD – using hdmi – hdmi or DVI – hdmi cables
  • Samsung 22″ LCD 1680×1050 – using DVI – DVI cable
  • Old Samsung 19″ LCD – using DVI – VGA (D-sub) – VGA cable

Under Screen resolution (Windows 7 Ultimate), trying to add 3rd display (extend desktop to this display), it always shows the following error window:
[Change Settings]
Unable to save display settings.
[ok]

I can enable any 2 monitors, but when I try to add third, it shows the same error. Some people have reported, that they have successfully enabled third display (for example Jeff Atwood from codinghorror). The thing is, that I have passive DisplayPort to DVI cable, but Jeff has Active DisplayPort to DVI, that cost $110. That’s insane! I can buy multiple ATI 3450 cards for that price and build at least 3+ monitor setup.

Now I am going to add one of my old ATI cards to existing setup, to fix this broken Eyefinity thing.

P.S. Also, I have strange issue with HDMI – HDMI cable when connected to LG LCD TV. With this cable I am unable to get satisfactory image (always black bars / borders and blurry fonts), so I am using DVI – HDMI cable. Some folks in ATI forums also have reported issues with HDMI – HDMI cables.

Update (thanks to Bill, July 12, 2010).
A maximum of 2 legacy monitors (VGA, DVI or HDMI) can be enabled simultaneously, provided that each monitor is connected either directly or via a “passive” DisplayPort adapter/dongle. “Passive” adapters/dongles will NOT support more than 2 legacy monitors.

ATI / AMD support site